The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: GTECH SW08 not charging  (Read 660 times)

Offline BaldEagle

  • Member
  • Posts: 7
GTECH SW08 not charging
« on: March 19, 2021, 12:36:29 PM »
Well - can anyone out there help me?
I have a very old, and much loved, GTECH SW08 but I made a big mistake the other day and plugged in the wrong charger. Unfortunately it was the same jack but different polarity / voltage and now it no longer charges. I can still use it but I have to unscrew the bottom door, remove the battery and charge it externally.
A REAL PAIN!

ila_rendered

ila_rendered

I opened the case and removed the charging circuit - one of the resistors seems to have burnt out. GTECH do not seem able or willing to help me with this information. All I need is to know the value of the blown resistor (or resistors?). BUT - I cannot read the value of this resistor! Does anyone have a similar model and be willing to have alook inside?

ila_rendered

ila_rendered

The board is AN-101704BR and the resistor is labelled R3 (R2 may also be damaged). Can anyone tell me the value of those resistors or a link to a circuit diagram?

THANKS!  :thumbsup:


[Image code fixed by mod]


Offline MVacs

  • Administrator
  • Member
  • *****
  • Posts: 5890
  • Country: gb
  • Gender: Male
    • Manchester Vacs -- The Independent Dyson Specialists
Re: GTECH SW08 not charging
« Reply #1 on: March 23, 2021, 02:53:09 PM »
I would expect Ryevac to be able to identify those by colour possibly. He is the board guru here. I'll link him

Offline BaldEagle

  • Member
  • Posts: 7
Re: GTECH SW08 not charging
« Reply #2 on: March 23, 2021, 03:02:03 PM »
THANKS

I could not make out the colours as they are slightly blackened.
Mind you my eyesight is not what it used to be.
Here are a few more photos (attached - I hope) to help Ryevac.

ila_rendered

ila_rendered

ila_rendered

Offline ryevac

  • Member
  • Posts: 610
  • Country: gb
  • Gender: Male
  • Optimism is the faith that leads to achievement
Re: GTECH SW08 not charging
« Reply #3 on: March 23, 2021, 09:20:52 PM »
Q1 will possibly be damaged also imo.
Sorry looking at the pics i cannot tell you the values due to the resistors burn out.
As you say best thing is for someone to open a good one up and take a pic
The only way to fail is not to try.


Offline BaldEagle

  • Member
  • Posts: 7
Re: GTECH SW08 not charging
« Reply #4 on: March 23, 2021, 11:09:46 PM »
Thanks for trying Ryevac and I will also try to get a new Q1 transistor.
It's a shame that Gtech do not seem to provide circuit diagrams.
In the meantime I will continue to charge the battery externally.

Offline ryevac

  • Member
  • Posts: 610
  • Country: gb
  • Gender: Male
  • Optimism is the faith that leads to achievement
Re: GTECH SW08 not charging
« Reply #5 on: March 24, 2021, 09:21:26 PM »
Ok, i couldn't even find a pic of the pcb on google.

Not familiar with the board, the to220 device next to r7 is an lm317 adjustable regulator, and r7 1.5k is probably the regulators output setting bias /Vref resistor.
Careful with Q1, as i ain't really sure looking at the pic to what it actually does and there could be other issues.
The only way to fail is not to try.

Offline BaldEagle

  • Member
  • Posts: 7
Re: GTECH SW08 not charging
« Reply #6 on: March 25, 2021, 09:17:39 AM »
Hi again ryevac and thank you for those details.

NO - I searched all over GOOGLE but could not find any details of this circuit and Gtech were no help whatsoever.
They do not advise dismantling the machine to the extent I have ('cause 6V can be very dangerous?).
And that Gtech would not be responsible to any damage or injury caused by my tampering (neither would any court in the land?).

You would think they, at least, would have a circuit diagram and the resistor values but they would not provide that information.
There would also be less danger of damage or injury if they gave me the correct resistor values.
Or, indeed, just offered to sell me the entire board?
But hey if he can't repair it he will have to buy a new one increase our profits and add to the landfill problem.

If I ever find out what the burnt resistors (R2 R3) are I was going to replace them and see if charging works again.
Mind you I'm getting more and more used to just removing the battery and charging it.

PLAN B is to wire in 2 small bolts of the outside of the units so that I can attach the crocodile clips from my battery charger without turning the Gtech upside down, unscrewing the cover and removing the battery.
Note to self: Empty dust before turning sweeper upside down - AGAIN!

Offline BaldEagle

  • Member
  • Posts: 7
Re: GTECH SW08 not charging
« Reply #7 on: March 25, 2021, 01:53:34 PM »
Here is a better photo of the circuit board (both sides)

ila_rendered

Offline ryevac

  • Member
  • Posts: 610
  • Country: gb
  • Gender: Male
  • Optimism is the faith that leads to achievement
Re: GTECH SW08 not charging
« Reply #8 on: March 25, 2021, 09:10:16 PM »
Ah, whats the part number of Q1 please  and the other black to92 device to its right in the picture.
The only way to fail is not to try.

Offline BaldEagle

  • Member
  • Posts: 7
Re: GTECH SW08 not charging
« Reply #9 on: March 25, 2021, 10:37:22 PM »
Q1 ST 8050D W8 LC
The other one 97TM052E TL431AC TI
Hope that helps.

ila_rendered

ila_rendered

Offline ryevac

  • Member
  • Posts: 610
  • Country: gb
  • Gender: Male
  • Optimism is the faith that leads to achievement
Re: GTECH SW08 not charging
« Reply #10 on: March 29, 2021, 11:46:55 PM »
Ok, leave it with me - am a bit up to my eyes in it at the moment.
The only way to fail is not to try.

Offline BaldEagle

  • Member
  • Posts: 7
Re: GTECH SW08 not charging
« Reply #11 on: March 30, 2021, 12:11:05 AM »
No problem ryevac whenever you have the time, I'm really grateful for you help.
By the way I seem to have added an extra T to the second "transistor" it should have said 97M052E TL431AC not 97TM052E TL431AC

Offline ryevac

  • Member
  • Posts: 610
  • Country: gb
  • Gender: Male
  • Optimism is the faith that leads to achievement
Re: GTECH SW08 not charging
« Reply #12 on: March 30, 2021, 09:37:50 PM »
TL431 is the important part number,  very common Vref device
The only way to fail is not to try.

 

 

FFP2 N95 Face Masks

 

 

Dyson Spare Parts

 

 

Freestanding Dyson Cordless Vacuum Stand

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

Sebo Vacuum Cleaners

 

 

Instagram

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacson Google+

Manchester Vacs on Instagram

Registration