The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: dc07 animal (US) has problem reattaching bin  (Read 1583 times)

Offline bs03

  • Member
  • Posts: 3
dc07 animal (US) has problem reattaching bin
« on: August 28, 2013, 03:15:45 AM »
I have had my Dyson for a long time and it has had this problem for a few years now.

After you empty the bin, the assembly may or may not snap back into place.  Sometimes it goes back on on the first try, sometimes it takes several tries.  I have even given up and left it unattached to fight with another time. 
If I have more vacuuming to do, I can hold the bin place while turning the power on and the vacuum pressure will hold the bin in place, but you have to catch the bin after you turn the motor off.

Since this is intermittant, it of course works when I take it to the repair shop.  I have spent a long time on the phone with cust service only to have them end up stumped.

I know that I can order new parts but nothing seems to need replacing.  It vacuums fine without any strange smells or noises.  Has anyone heard of this problem?  My husband sees the only answer as buying a new one.

Thanks.

Online MVacs

  • Administrator
  • Member
  • *****
  • Posts: 4647
  • Country: gb
  • Gender: Male
    • Manchester Vacs -- The Independent Dyson Specialists
Re: dc07 animal (US) has problem reattaching bin
« Reply #1 on: September 02, 2013, 07:23:50 PM »
Look at the grille below the cyclone that holds the post motor filter in, if that is disturbed or not seated correctly, it can do as you describe.

A photo of the bit it snaps into and the back of the cyclone top handle - close up - may help if we can see anything missing or worn.

Offline bs03

  • Member
  • Posts: 3
Re: dc07 animal (US) has problem reattaching bin
« Reply #2 on: September 02, 2013, 08:01:37 PM »
This started happening before I had my post filter changed.  After changing the filter, it still happens. Several different people have opened and reset that cover because everyone thinks that has to be the problem. 

I think the problem is with the bin. 
When the bin won't latch back on, sometimes opening and reclosing the bin helps. 
Sometimes it will latch on again after I use the vacuum a bit and reempty the bin.
This makes me believe that there is a problem with part of the bin. 

The bottom flap always seems to latch securely on one try, and never has problems opening.
When the power is turned on there is good suction, so it seems that all of the seals are working.

I don't want to order a whole new assembly if I can figure out which part is bad.

Thanks.

Online MVacs

  • Administrator
  • Member
  • *****
  • Posts: 4647
  • Country: gb
  • Gender: Male
    • Manchester Vacs -- The Independent Dyson Specialists
Re: dc07 animal (US) has problem reattaching bin
« Reply #3 on: September 03, 2013, 12:14:12 AM »
US models have the double lock handle. Does that appear to function properly?

When the bin is off, the bin release trigger works visibly OK?

Look at the chassis where the bin clips to. Does nothing look chipped there? Its just a question of looking what exactly is obstructing it when it does it really.

Offline bs03

  • Member
  • Posts: 3
Re: dc07 animal (US) has problem reattaching bin
« Reply #4 on: September 10, 2013, 02:03:32 AM »
I'm sorry I haven't written more sooner.  It has been behaving again, so there isn't much to see.

I took off the clear bin and looked up into the cone while working the flap release.  It seems to be working.  When you pull up on the release trigger, the clasp swings to the side and the bar pushes down.  When you release the trigger, the bar retracts and the clasp swings back into place.

When you look at the main unit there does not seem to be any real damage.  There are some minor scratches, but they aren't where the bin sits (think trying to vacuum under furniture and such). 

I had thought about the gaskets that are behind the bin but they seem intact and when you watch it fail they do not seem likely.

I also checked the bin flap which shows no signs of any damage.  I was wondering if the bin flap gasket should be replaced.  It seems a bit worn and thin but not actually damaged, so I doubt that it could be the problem.

I also checked the thumb latch to remove the assembly from the upright. It moves up and down freely with no visible damage to it either.

As soon as it acts up again, I will look at everything again.  I'll also try to get pics and/or vid.

DC07 Spare Parts


 

 

Dyson Spare Parts

 

 

Sebo Vacuum Cleaners

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

The Dyson Medic Blog

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacson Google+

Manchester Vacs on Instagram