The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: YV-511 issues?!  (Read 456 times)

Offline Elgin

  • Member
  • Posts: 731
  • Country: england
  • Gender: Male
YV-511 issues?!
« on: March 16, 2017, 02:18:21 AM »
So when my DC07 YV-2200 blew up I shoved a YV-511 in there. Not too bad! works amazing despite lower suction slightly.
Now heres the "issue"


After I chopped my cyclones from a 1 to a 2 sized and forgot to put my filter in - even though not one spec of dust makes it to the fan pipe - let alone the filter my motor has begun sparking!

Now I noticed it whilst replacing my post-filter - I wondered what the motor was like and I turned it on and saw a little blue flash through the diffuser - at the back of the housing - only during the first second you press the button - runs fine, no sparking except at first second, smooth, no smell of burning or eccesive carbon dust.

It remind me of my old DC07 Origin - who was the late model with the white motor housing etc, and I saw whilst I had the  belt off the entire motor casing lit up when it was running and thought this was usuall - couldn't of been since the next time I used it it blew a fuse the second I turned it on - put a new en in - presses the button and Zoooooom! Motor ran for a second until the other fuse burnt through and so on - I just part-exed it for a DC04 Absolute which now my nan owns and I have a De Stijl

So that brings me to the question:
Is this blue light up at the rear of the motor housing on first strike up normal? If not how long has me motor got in it? and would I be able to replace the carbons with the spares I happen to have hanging around somewhere from my siezed motor because I accidentally got a bit of screen cleaner on the bearing and it ate all the oil... Never do that!

Online Madrat

  • Member
  • Posts: 2744
  • Country: england
  • Gender: Male
Re: YV-511 issues?!
« Reply #1 on: March 16, 2017, 01:57:28 PM »
Normal, and so are tiny flashes during use, its when there are big fat blue flashes with growling popping noises that you have a problem.

Offline Elgin

  • Member
  • Posts: 731
  • Country: england
  • Gender: Male
Re: YV-511 issues?!
« Reply #2 on: March 16, 2017, 09:06:25 PM »
Normal, and so are tiny flashes during use, its when there are big fat blue flashes with growling popping noises that you have a problem.

Thought they were normal - dont think my old dc07 origin was though - massive blue flashes next to the belt and everything

Afterwards I checked our late silver and darksteel DC14 Animal and that was doing the same - tiny flash at startup so I thought it was nromal

DC07 Spare Parts


 

 

Dyson Spare Parts

 

 

Sebo Vacuum Cleaners

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

The Dyson Medic Blog

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacson Google+

Manchester Vacs on Instagram