The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: V7 - No power/suction but solid blue light  (Read 773 times)

Offline adame10

  • Member
  • Posts: 3
V7 - No power/suction but solid blue light
« on: March 09, 2021, 04:41:02 PM »
I'm getting no power or suction when depressing the trigger on my V7 animal (with no attachment).

A solid blue light appears as long as I hold the trigger for, as well as when it's charging, so it doesn't feel like a power issue?

Worth saying that i've taken it apart and cleaned fairly thoroughly...

Any ideas? Apologies if a similar issue has been covered elsewhere.


Offline MVacs

  • Administrator
  • Member
  • *****
  • Posts: 5968
  • Country: gb
  • Gender: Male
    • Manchester Vacs -- The Independent Dyson Specialists
Re: V7 - No power/suction but solid blue light
« Reply #1 on: March 09, 2021, 04:54:17 PM »
Was it working before you took it apart or not?

When you say no power, you mean it doesn't run at all?

Offline adame10

  • Member
  • Posts: 3
Re: V7 - No power/suction but solid blue light
« Reply #2 on: March 09, 2021, 05:03:14 PM »
Yeah, it doesn't run at all. It's as if I'm not pressing the trigger, except that the solid blue light comes on.

It wasn't working before I took it apart.

Offline adame10

  • Member
  • Posts: 3
Re: V7 - No power/suction but solid blue light
« Reply #3 on: March 09, 2021, 05:05:41 PM »
Sorry, i should have said.

I'd been hoovering after sanding some woodwork. I suspected the issue was caused by dust build up, that's why I took it apart/cleaned.


 

 

Trade Dyson Spare Parts

 

 

Dyson Spare Parts

 

 

Freestanding Dyson Cordless Vacuum Stand

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

Buy a police truncheon

 

 

Instagram

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacs on Instagram