The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: Dyson V7 Power and Motorhead problems got me stumped  (Read 173 times)

Offline kwells123

  • Member
  • Posts: 9
  • Country: gb
  • Gender: Male
Dyson V7 Power and Motorhead problems got me stumped
« on: November 03, 2021, 01:21:12 PM »
So I am currently attempting repairs on a V7 which has come in with problems of the motorhead not working.
voltage tested at the main body, bin and wand and is all fine.

So a new motorhead was purchased, when attached to either connection not only does the motorhead not work but also no power from the main unit, but there is a solid blue light on the battery, so the unit is responding to the trigger being pressed.

Without the motorhead attached the Dyson works fine.

This has now been tried and tested with 2 brand new motorheads and the same result from both.

This is not something I have ever come across so would appreciate any help. I have seen that a few other people have had similar problems, but there doesn't seem to be a solution on their thread.

At a guess I would be thinking that its a fault with the main board inside. But just wondered if anyone could help, before further tests etc...

Many thanks :)


Offline MVacs

  • Administrator
  • Member
  • *****
  • Posts: 6001
  • Country: gb
  • Gender: Male
    • Manchester Vacs -- The Independent Dyson Specialists
Re: Dyson V7 Power and Motorhead problems got me stumped
« Reply #1 on: November 05, 2021, 05:17:34 PM »
Sounds like the main board inside as you say. We usually replace the motor body in that situation.

 

 

Trade Dyson Spare Parts

 

 

Dyson Spare Parts

 

 

Freestanding Dyson Cordless Vacuum Stand

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

Buy a police truncheon

 

 

Instagram

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacs on Instagram

Registration