The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: Dyson V10 wont give power to brush  (Read 420 times)

Offline anartio

  • Member
  • Posts: 2
  • Country: 00
  • Gender: Male
Dyson V10 wont give power to brush
« on: April 08, 2024, 09:20:50 am »
Hope for your help.
I have got problem "not spinning any brush" with Dyson V10 Animal.
Everything works fine, except brushes. 
I found in internet a self-made schema of similar VC (not sure it fully correct). I also got V17 from a friend of mine for testing.
What I have done before this topic:
With an oscilloscope I checked what was going on when V10/V17 starts without connected brush.
And I got a same graph pattern on both VCs.
On good V17 pcb starts PWM output voltage on terminals (16 volts).
On broken V10 with connected brush : tries to start for short amount of time and instantly stops (by graph on oscilloscope same as like it not connected)
And I swapped U24, and U13 (ICs on schema) from V17 to V10 . And this ICs is absolutely OK.
At this point I can assume that V10 can't see a connected accessory brush.

 Unfortunately, lack of knowledge can't lead me to solution. I cant't understand how V10 get OK signal when brush connected.
 Hope that somebody helps me find a solution.
 Regards, Andy
dyson v10 animal


Offline anartio

  • Member
  • Posts: 2
  • Country: 00
  • Gender: Male
Re: Dyson V10 wont give power to brush
« Reply #1 on: April 08, 2024, 01:44:09 pm »
brush motor schema part
dyson v10 animal


 

 

Trade Dyson Spare Parts

 

 

Dyson Spare Parts

 

 

Freestanding Dyson Cordless Vacuum Stand

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

Buy a police truncheon

 

 

Instagram

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacs on Instagram

Registration