The World's #1 Vacuum Cleaner Advice, Repair, Discussion & Information Forum

Author Topic: poor suction / pick-up at cleaning head  (Read 1827 times)

Offline sy278

  • Member
  • Posts: 1
poor suction / pick-up at cleaning head
« on: April 24, 2012, 11:09:10 AM »
Hi Guys,

Looking for some advice please.

My parents have a DC07 Allergy (purple/lime) which for the past while has not been picking up much at the main cleaning head, though the tools seem fine.

So to try to fix it I stripped the vac down and cleaned it all out, the sole plate was caked solid blocking the inlet to the flexible hose that connects the head to the carriage. We cleaned this out and cleaned out all the hoses and pipes.

I checked the cyclones, they are not blocked, but cleaned the dust out anyway. The filters have been cleaned (Pre and Post) and the machine has been tested with and without the filters in place.

To check the carriage I disconnected the small flexible hose from the sole plate and put my hand over it, with the handle in the upright position, no suction as expected. Next I clicked the head into cleaning position and immediately the hose sucked onto my hand with quite a bit of force, at this point I also checked the brush bar was running, as I had not disengaged the clutch, which it was.

As far as I can tell the seals are all good.

The vac is picking up again, but still seems to be lacking in power. Its no longer 'lifting' the carpet as it used to. Is there something I have missed or can you suggest anything else to check?

DC07 Spare Parts


 

 

Dyson Spare Parts

 

 

Sebo Vacuum Cleaners

 

 

Buy a Dyson DC04 Wand Handle

 

 

 

 

The Dyson Medic Blog

Dyson Spares, Parts, Advice   Follow us on Twitter

Manchester Vacson Google+

Manchester Vacs on Instagram